Geary Email Client 0.11发布-如何在Linux上安装

Geary电子邮件是针对GNOME 3桌面环境构建的免费开源电子邮件许可证(根据LGPL v2.1许可)。 Geary轻巧,因为它没有RSS阅读器或Thunderbird那样的日历。 它不支持POP3,因此您将被迫使用IMAP协议阅读电子邮件。 Geary电子邮件旨在成为一个简单而现代的电子邮件客户端。

Geary email 0.11.0于2016年5月15日发布。此版本带来了许多错误修复和改进:

  • 添加存档特殊文件夹支持
  • 添加is:已读,is:未读:is:已加星标的搜索运算符
  • 使用多个搜索运算符进行修正-到:,从:等
  • 解决由WebKitGTK + 2.4.10引起的崩溃
  • 修复搜索时崩溃
  • 修复某些HTML消息中未显示的图像
  • 从通知中打开时修复主窗口为空
  • 修复网络连接丢失时UI冻结的问题
  • 网络不可靠时,可与Cyrus和其他服务器更好地协作
  • 在SQLite 3.12和更高版本中启用自定义FTS3标记程序的使用
  • 修复Composer’Detach’按钮位置不一致的问题
  • 文档改进
  • 更新Deb模块依赖项
  • 更新了UI翻译
  • 更新了文档翻译

如何在Linux上安装Geary Email Client 0.11.0

您可以使用以下命令从发行版本存储库中获取Geary,但它不一定是最新版本。

Debian/Ubuntu/Linux Mint:  sudo apt-get install geary

Fedora: sudo dnf install geary

Arch Linux: sudo pacman -S geary

要在Ubuntu和Fedora上安装Geary 0.11.0,请遵循以下说明。

首先,从https://download.gnome.org/sources/geary/0.11/下载压缩包。 您也可以打开终端窗口,然后复制以下命令进行下载。

wget https://download.gnome.org/sources/geary/0.11/geary-0.11.0.tar.xz

然后提取压缩包。

tar xvf geary-0.11.0.tar.xz

在Ubuntu 16.04中为Geary安装构建依赖项。 intltool用于生成.desktop文件。

sudo apt-get install valac libgirepository1.0-dev intltool cmake desktop-file-utils gnome-doc-utils libcanberra-dev libgee-0.8-dev libglib2.0-dev libgmime-2.6-dev libgtk-3-dev libsecret-1-dev libxml2-dev libnotify-dev libsqlite3-dev libunique-3.0-dev libwebkitgtk-3.0-dev libmessaging-menu-dev libunity-dev libgcr-3-dev

通过运行以下命令,在任何版本的Fedora中安装Geary的构建依赖项:

sudo yum install gobject-introspection-devel intltool cmake desktop-file-utils gnome-doc-utils libcanberra-devel libgee-devel glib2-devel gmime-devel gtk3-devel libnotify-devel sqlite-devel unique3-devel webkitgtk3-devel libsecret-devel libxml2-devel vala-tools gcr-devel

将CD放入目录并构建Geary。

cd geary-0.11.0/
./configure
make

现在运行以下命令进行安装。

sudo make install

要卸载,请运行

sudo make uninstall

Geary将安装在/ usr / local / bin下。 您可以运行此命令来启动Geary。

geary

您可以设置Gmail,Yahoo! 邮件和Outlook.com帐户在Geary中。 如果您拥有自己的电子邮件服务器,则也可以使用Geary进行设置。 请注意,Geary不支持POP3,因此您将被迫使用IMAP协议来阅读电子邮件。

Geary设置电子邮件帐户

您的电子邮件密码安全地存储在Gnome密钥环中。 我必须承认,此设置过程非常简单明了。

gnome的Geary电子邮件客户端

要在Geary中添加多个电子邮件帐户,请转到 吉利 > 帐目

Geary添加新帐户

更新: 适用于Geary的新PPA可用于Ubuntu 16.04 / 15.10 / 14.04,其中包含最新版本的Geary。

sudo add-apt-repository ppa:geary-team/release

sudo apt-get update

sudo apt-get install geary

更新: Geary 0.11现在位于Arch Linux存储库中。

我希望本文能帮助您在Linux上安装Geary电子邮件客户端。 总是欢迎提出意见,问题和建议。 如果您认为这篇文章有用,请订阅我们的免费新闻通讯,或在Google +,Twitter或喜欢我们的Facebook页面上关注我们。

Sidebar