适用于Ubuntu 20.04、19.10、19.04和18.04的新快门PPA | Linux Mint 19.x

百叶窗 屏幕快照工具最近已从Debian Unstable和Ubuntu 18.10(将于明天发布)中删除。使用来自Linux Uprising的新的Shutter PPA,包括允许您编辑屏幕快照,添加注释甚至获取完整网页的屏幕快照的所有依赖项,Ubuntu 20.04、19.10,仍然可以在19.04、18.10和18.04上安装。
一个流行的使用Gtk2和Perl的截图工具是阻止Debian(和Ubuntu)删除过时软件包的少数软件包之一。 libgnome2-perllibgnome2-vfs-perl 从资源库存档。由于没有这些套件,百叶窗将无法工作, 已删除 来自 德比安 不稳定的Ubuntu 18.10存储库

发生这种情况是因为六个月前已从Ubuntu 18.04和Debian Buster中删除了一些可选的依赖项,并且不需要编辑应用程序,除非用户从旧版Ubuntu或Debian中手动安装了这些软件包。 /注释功能停止工作。
当快门仍然关闭时 发展历程尽管它在2017年重新获得了新的开发人员,但移植使用不推荐使用的Perl模块和Gtk3似乎没有进展。在这种情况下,快门将不会返回Debian和Ubuntu。如果您可以提供协助,请参阅专案页面 发射台
您可以提供帮助的另一种方法是为百叶窗创建快照和/或Flatpak软件包。这对于使用较旧库的百叶窗非常理想,因为此类软件包包含运行该应用程序所需的库。当前没有用于快门的Snap或Flatpak软件包。快门有多种选择,例如Ksnip和Flamshot。

Ubuntu /流行!如何在OS / Linux Mint上继续使用快门

如果我想使用快门怎么办?由于我每天都使用Shutter,因此我为Shutter及其依赖项创建了PPA,以便其他人喜欢它而不是其他屏幕截图工具仍可以使用它。我当时正在创建Snap或Flatpak,但是现在我没有时间考虑如何创建这样的程序包。
PPA包括最新版本的Shutter(比Ubuntu 18.04中可用的更新版本),Ubuntu 19.04和18.10所需的依赖项以及可选的依赖项。该PPA不仅在Ubuntu 20.04、19.10、19.04和18.10上缺失,而且在Ubuntu 18.04 / Linux Mint 19或19上也缺失。这是因为存在可选的Shutter依赖性。这些依赖项增加了对编辑/注释快门图像的支持以及AppIndicator的支持。借助内置的AppIndicator支持,这使您可以在Ubuntu 18.04上显示快门托盘图标而无需启用托盘。
您可以添加PPA并使用以下命令在Ubuntu(或Pop!_OS)18.04、18.10、19.04、19.10或20.04 / Linux Mint 19.x上安装Shutter:

sudo add-apt-repository ppa:linuxuprising/shutter
sudo apt-get update
sudo apt install shutter

编辑:我还添加了 gnome-web-photo 打包为PPA。使用此软件包,Shutter可以截取整个网站的屏幕快照(无论高度如何,您都可以在一张图像中截取整个网站的屏幕快照)。 Ubuntu 18.04或更高版本/ Linux Mint19。*不可用。 (使用Ubuntu 20.04减号添加PPA后,可以安装PPA支持的所有Ubuntu版本。 gnome-web-photo 对于Ubuntu 20.04,因为无法获得 webkitgtk 成功构建):

sudo apt install gnome-web-photo

安装完成后,重新启动快门并单击网站屏幕截图按钮(或选择 Web 输入网站URL(从指示器/任务栏图标开始),快门将在几秒钟内完成屏幕截图。

Sidebar