Ubuntu Make Developer Tools Installer 18.05添加了对Atom Beta,Eclipse Javascript的支持并重新启用Unity3D

Ubuntu Make已更新至版本18.05,该应用程序可让您在Ubuntu系统上安装开发人员工具。它包括新的IDE,例如Atom Beta,Goland,Eclipse JavaScript,修复程序和其他改进。
Ubuntu Make是一个命令行工具,可以轻松地在Ubuntu和Linux发行版(如Linux Mint和基本OS)上下载和安装流行的开发人员工具的最新版本。
该工具处理从安装所需的依赖项到将已安装的工具集成到桌面环境中的所有工作。另外,您可能需要注销/登录才能在菜单中查看IDE或其他开发工具。
Ubuntu Make可以设置50多个开发环境,包括Android Studio,Golang,ItelliJ IDE,Visual Studio Code和Rust。

最新的Ubuntu Make 18.05包含对5个新IDE的支持。

  • Eclipse Javascript
  • 原子beta
  • 处理中
  • 高地
  • Visual Studio代码内幕

还重新启用了Spring Tools,并修复了Visual Studio Code依赖性。
其他IDE更改包括将env变量添加到Android Studio,将StartupWMClass添加到Firefox Developer和Visual Studio Code。
Ubuntu Make Games类别已获得一些新工具:

  • 戈多引擎
  • 开发
  • 搅拌机

另外,将重新启用Unity3D。
Ubuntu Make 18.05中的其他更改:

  • 对执行使用符号链接
  • Eagle添加到新的电子产品类别
  • 增加了水晶郎
  • 添加Maven
  • 网站:添加PhantomJS

安装Ubuntu Make

从PPA或snap软件包安装Ubuntu Make。请勿同时安装。下面是这两个安装选项的列表。
通过官方PPA在Ubuntu或Linux Mint上安装Ubuntu Make。 每一天稳定的

  • 每日PPA:
sudo add-apt-repository ppa:lyzardking/ubuntu-make
sudo apt update
sudo apt install ubuntu-make
  • 稳定的PPA:
sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
sudo apt update
sudo apt install ubuntu-make

阅读:尝试安装开发人员工具时,Ubuntu Make snap软件包可能会出现段错误。 这个 根据错误报告,这是一个已解决的问题,而不是Ubuntu Make问题。如果发生这种情况,请使用上述两个PPA之一或使用最新的Ubuntu Make代码。 的GitHub
建议使用Ubuntu Make页面 ubuntu-make.umake 如果该工具是从snap安装的。
有关如何使用Ubuntu Make的说明,请在终端中运行此命令:

umake --help

这是一个例子。要安装刚添加到Ubuntu Make 18.05中的Atom Beta,可以使用:

umake ide atom --beta

然后按照说明进行操作。
或对于Eclipse Javascript,请执行以下操作:

umake ide eclipse-javascript
Sidebar