发行摘要:乔普林1.0.195,Audacious 4.0,Meteo Qt 1.6和Gammy 0.9.58

周末有四个应用程序,本文将简要概述它们。

  • Joplin添加了实验性WYSIWYG编辑器(免费,开源备忘录编写和To-Do应用程序)1.0.195
  • 默认情况下,Audacious(音乐播放器)4.0已切换到Qt5,GTK2版本将不再接收新功能
  • Gammy(自适应屏幕亮度)0.9.58是一个针对基于位置的温度的错误修复版本。
  • Meteo Qt(用于显示天气信息的托盘应用程序)1.6进行了一些小改动

Joplin 1.0.195添加了所见即所得的实验编辑器

乔普林 是用于Linux,Windows,macOS,Android和iOS的免费,开源笔记记录和待办事项应用程序。它具有端到端加密和Markdown支持,尽管它不提供自己的同步服务,但是您可以使用第三方服务,例如OneDrive,NextCloud,Dropbox(也支持WebDAV)。 Joplin的最新稳定版本1.0.195添加了新的实验所见即所得(WYSIWYG)编辑器。所见即所得(所见即所得)是一个系统,该系统允许编辑软件以在打印或显示为最终产品时的外观方式来编辑内容。

乔普林1.0.195中的其他更改:

  • 添加了一种升级主密钥加密和同步目标加密的方法
  • API:添加了对注释PUT请求的“标记”属性的支持
  • 添加了显示/隐藏乔普林的全局快捷方式:在Linux和Windows上为Ctrl + Alt + J,在macOS上为Cmd + Opt + J
  • 快速删除笔记本
  • 增强笔记列表的焦点行为
  • 当插入符号在项目符号后时,通过按Tab缩进列表
  • 错误修复

有关更多信息,请参见以下文章:Joplin:加密的开源笔记记录和待办事项应用程序

大胆的4.0默认情况下切换到Qt5,GTK2版本将不再接收新功能

粗体4.0 Qt5粗体 一个免费的开源音频播放器,它是XMMS的后代,可在Linux,* BSD和Windows上运行。它带有图形均衡器,LADSPA效果,插件以及两个接口GTK2和Qt5。它还支持Winamp Classic皮肤。在最新的Audacious 4.0版本中,默认情况下,音乐播放器切换为Qt5。 GTK2用户界面仍然可用并受支持,但是不会添加任何新功能。
自从首次推出以来,Audacious Qt5界面已有了很大改进,但仍然缺少一些功能,例如“跳转到歌曲”窗口。还鼓励开发人员暂时使用GTK2版本,甚至对于Winamp等用户界面的用户也是如此。
另请注意,Microsoft Windows二进制文件将继续使用GTK2版本。 “直到Qt版本解决Windows特定的字体大小问题(显示器上超过96 DPI)。”
Audacious 4.0中的其他更改:

  • 点击播放列表列标题以对播放列表进行排序
  • 拖动播放列表列标题以更改列顺序
  • 音量和时间步长的应用程序范围设置
  • 隐藏播放列表标签的新选项
  • 按路径对播放列表进行排序现在可以对文件进行排序
  • 实施了附加的MPRIS调用以与KDE 5.16+兼容
  • 新的基于OpenMPT的跟踪器模块插件
  • 新的VU仪表可视化插件
  • 添加了使用SOCKS网络代理的选项
  • Song Change插件现在可以在Windows上使用
  • 新的“下一个相册”和“上一个相册”命令
  • 现在,您可以使用Qt UI标记编辑器一次编辑多个文件
  • 在Qt UI中实现了均衡器预设窗口
  • 歌词插件已具备在本地保存和加载歌词的功能
  • 可视化的Blurscope和频谱分析仪已移植到Qt
  • 将MIDI插件移植到Qt的SoundFont选择
  • 一些新选项已添加到JACK输出插件
  • 添加了无限期循环PSF文件的选项
  • 对介子构建的实验支持

对于大多数Linux发行版,Audacious 4.0尚未在官方存储库中提供。在撰写本文时,甚至Arch Linux资源库都没有使用Audacious的最新版本进行更新(但 git Aur软件包 对于较新的版本)。
Ubuntu(和Pop!_OS,Linux Mint等)的用户 非官方的PPA 但是,此PPA包含许多其他软件包,因此您可以为不需要的软件包获取更新。为避免出现问题,您只能添加它以安装Audacious,然后将其删除。

橡皮糖0.9.58

适用于Windows和Linux(x11)的Gammy自适应屏幕亮度软糖 定期拍摄屏幕截图以根据屏幕内容调整像素亮度;如果看起来太亮,则使屏幕变暗;如果内容太亮,则使屏幕变亮自适应屏幕亮度工具(带有Qt5托盘/ GUI)。太黑了在Microsoft Windows和Linux上可用(仅X11,因此在Wayland上不起作用)。
Gammy 0.9.58的变化:

  • 在某些时间间隔内修正了错误的温度条件(需要额外的测试)
  • 纠正突然的温度变化
  • 修复与配置文件相关的崩溃
  • 对并非总是保存的设置进行推测性更正
  • 在配置中添加了动画帧频设置。亮度和温度分别为“ brt_fps”和“ temp_fps”
  • 默认值为60 FPS(亮度)和45 FPS(温度)。如果性能有问题,请尝试降低性能

Gammy 0.9.58发行版是为了准备一项主要的新功能(基于位置的温度)而创建的,预计将在新发行版中发布。

关于此的更多信息:Gammy:适用于Linux的自适应屏幕亮度工具(包括有关安装Fedora的说明,该说明不在Gammy存储库页面上)。

Meteo Qt 1.6

流星Qt流星Qt PyQt5托盘应用程序用于显示天气信息。除了显示当前天气(针对您可以添加到设置中的位置和其他自定义位置)之外,您的应用程序还可以在用户界面中显示天气预报,并在桌面上显示有关天气变化的通知。你也可以
应用程序必须为创建一个帐户 OpenWeatherMap.org 从中获取您自己的API密钥,并在Meteo Qt中使用它。
Meteo Qt 1.6的变化:

  • 像T°
  • 选择在托盘图标上显示类似T°的感觉
  • 使用系统主题图标的选项
  • 更新翻译

Sidebar