ERR_SSL_VERSION_OR_CIPHER_MISMATCH

当浏览器无法建立与Web服务器的安全连接时,浏览器中将显示ERR_SSL_VERSION_OR_CIPHER_MISMATCH错误。 SSL证书很常见,因为它们提供了网站和Web浏览器之间的安全和加密连接。 SSL证书用于需要加密敏感数据(例如信用卡号和个人信息)以使您可以安全地接受付款,转移数据,登录到Web表单等情况。但是,如今SSL证书已成为标准协议。对于任何网站,Google都敦促所有网站管理员在其网站上实施SSL证书。 今天,我们将向您展示如何解决ERR_SSL_VERSION_OR_CIPHER_MISMATCH错误。

所有流行的浏览器(例如Chrome,Firefox,IE或Safari)都支持SSL证书。 SSL证书出现问题时,Web浏览器会显示一条错误消息,以帮助您更好地理解该问题。 您在网络浏览器中看到的错误消息之一 ERR_SSL_VERSION_OR_CIPHER_MISMATCH… 这将阻止对网站的访问,因此,找出导致此错误的原因非常重要。

这是浏览器将显示的屏幕截图。

“无法建立安全连接,因为该站点使用了不受支持的协议。 错误代码:“ ERR_SSL_VERSION_OR_CIPHER_MISMATCH”。

导致ERR_SSL_VERSION_OR_CIPHER_MISMATCH错误的原因

当您使用旧的Web浏览器或操作系统时,通常会出现此问题,但有时可能还有其他原因,例如SSL证书有问题。 有几个简单的步骤可帮助您确定问题的原因。

  • SSL证书错误
  • 浏览器缓存和Cookie不会清除
  • 不包括TLS 1.3支持
  • QUIC协议未禁用
  • 网站被防病毒或防火墙阻止
  • 其他原因

以下是解决ERR_SSL_VERSION_OR_CIPHER_MISMATCH错误的可能解决方案。

1.检查SSL证书

当然,调试此问题的第一步就是检查SSL证书,并确保一切正常。 要检查SSL证书是否一切正常,可以使用免费的在线SSL验证工具。 有许多免费的在线服务,可让您对特定网站的SSL证书集进行深入分析。 我们建议您使用Qualys SSL Labs提供的一种,因为它非常完整。

如果您使用的是Linux VPS托管,并且服务器上安装的SSL证书有问题,可以联系我们的Linux专家,他们将帮助您立即解决问题。 他们24/7可用。

2.清除您的Web浏览器历史记录/缓存。

ERR_SSL_VERSION_OR_CIPHER_MISMATCH错误的另一种解决方案是清除保存的Web浏览器数据,例如历史记录/缓存。 根据您使用的Web浏览器,此步骤可能会有所不同。 如果您不确定如何清除浏览器中保存的数据,则可以在Google中搜索有关实现此目标需要采取哪些措施的信息。 某些网络浏览器允许使用键盘快捷键,因此如果您点击 CTRL + SHIFT + DELETE,您将立即可以访问空白页面的浏览数据。

在网络浏览器中清除保存的数据后,您可以尝试访问该网站,看看是否可以解决问题。

3.在Web浏览器中启用TLS 1.3支持。

ERR_SSL_VERSION_OR_CIPHER_MISMATCH错误的另一个常见解决方案是在Web浏览器中启用TLS 1.3支持。 Google Chrome浏览器允许您安装最低SSL / TLS版本。 在搜索中输入字符串 chrome://flags 然后按 Enter… 然后寻找 TLS 1.3… 可以在Web浏览器中启用此设置。 如果禁用此设置,则可以启用它并关闭选项卡。 您需要重新启动Web浏览器才能使更改生效。

4.禁用QUIC协议

如果在浏览器中启用了QUIC协议,您也可以尝试禁用它。 打开谷歌浏览器,在搜索中输入字符串 chrome://flags 然后按 Enter打开设置页面。 搜索, Experimental QUIC protocol如果启用此选项,则将其禁用。 进行更改后,关闭选项卡并重新启动Web浏览器以使更改生效。 然后尝试再次访问该网站,并检查问题是否已解决。

5.禁用防病毒软件。

本地计算机上安装的防病毒软件也会阻止对该网站的访问。 您可以暂时禁用防病毒软件,然后尝试再次访问该网站。 如果仍不能解决问题,您还可以检查防火墙,并确保未将网站添加到防火墙黑名单中。

6.其他解决方案

如果没有建议的解决方案解决此问题,则可以尝试重新安装Web浏览器和/或在Web浏览器中启用的扩展程序。 另外,如果您使用的是Windows XP等较旧的操作系统,则可能需要考虑升级操作系统。 较旧的系统不支持TLS 1.3等最新技术和最新的加密套件。

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Sidebar