Gpredict-卫星跟踪应用

Gpredict是用于Linux桌面的实时卫星轨道和轨道预测程序。 它使用SGP4 / SDP4传播算法以及NORAD两行元素集(TLE)。

Gpredict的一些主要功能包括:

  • 跟踪大量卫星,仅受物理内存和计算机处理能力的限制
  • 在列表,地图,极坐标图中以及这些的任意组合中显示跟踪数据
  • 在同一屏幕或记事本中或在自己的窗口中打开了许多模块。 模块也可以全屏模式运行
  • 您可以使用许多地面站
  • 预测即将到来的通行证
  • Gpredict可以实时运行,实时模拟(快进和快退)以及手动时间控制
  • 实时和非实时的详细信息
  • 通过Hamlib rigctld对广播电台进行多普勒调谐
  • 通过Hamlib rotctld控制天线旋转器

要求

该应用程序是使用Gtk + 3小部件集编写的,该部件集可用于大多数Unix,Mac和Windows操作系统。 要成功编译Gpredict,需要以下库:

  1. GTK + 3或更高版本
  2. GLib 2.32或更高版本
  3. GooCanvas 2
  4. Libcurl 7.16或更高版本
  5. Hamlib(仅运行时,不需要构建)

如果从源代码进行编译,则还需要软件包名称中带有-dev或-devel的开发软件包,例如libgtk-3-dev。 在Debian和Ubuntu系统上,可以使用以下命令安装构建依赖项:

sudo apt install libtool intltool autoconf automake libcurl4-openssl-dev 
sudo apt install pkg-config libglib2.0-dev libgtk-3-dev libgoocanvas-2.0-dev

要从源代码构建和安装应用程序,请首先解压缩源软件包:

tar -xvf gpredict-xyztar.gz

然后转到gpredict-xyz目录并创建一个gpredict:

./configure 
make 
make install

最后一步通常需要您成为root用户,否则您可能没有安装它所需的权限。 如果您不能或不想以根用户身份安装gpredict,则可以通过在-/ configure步骤中添加-prefix = somedir来将其安装在自定义目录中。 例如

./configure --prefix=/home/user/predict

will configure the build to install the files into /home/user/gpredict folder.

如果直接从git仓库构建,则需要运行./autogen.sh而不是configure。 您可以将与配置脚本相同的参数传递给autogen.sh脚本。

使用应用程式

它与一些示例数据捆绑在一起,将立即可用。

一旦感觉到用户界面,就可以更改默认模块设置(单击右上角的小向下箭头),也可以通过“文件”->“新模块”创建新模块。

强烈建议您查看位于http://gpredict.oz9aec.net/documents.php的用户手册。

用户支援

用户支持通过Libre Space Foundation主办的Gpredict论坛提供:https://community.libre.space/c/gpredict

条款和条件

它是根据GNU通用公共许可证发行的,不包含任何保证。 如果您在安装或使用Gpredict时遇到任何问题,请不要犹豫,例如在Libre Space Foundation主办的论坛上寻求支持。

请禁用您的广告拦截器或将此网站列入白名单!

Sidebar